The MinnowBoard Chronicles Episode 23: Trying Wind River Pulsar Linux, and taking a break

I’ve been stymied on both fronts: my MinnowBoard Turbot finally stopped recognizing the keyboard, and my home computer build machine has crashed!

In Episode 21, Building and Installing Linux Part 2, I vented my frustrations in getting the MinnowBoard to install Ubuntu Linux. Once I got past the EFI shell, the Minnow would stop taking keyboard input. So, I’d be sitting there staring at the Ubuntu installation screen; so near, and yet so far. Everything I tried, including using different keyboards, swapping the keyboard and USB flash stick between USB ports, using different USB flash sticks, etc. etc. were to no avail.

I even tried installing Wind River Pulsar Linux instead of Ubuntu. There are some very clear instructions on the MinnowBoard site here. But, alas, I would again get to a stage in the installation process, and could get no further. Note to self: look up “linux promiscuous mode” sometime:

Pulsar pic 0

And now, the Minnow won’t take keyboard commands even at the EFI shell (this used to work). I’ve googled this extensively, and the closest I can seem to get to a diagnosis is in some of its Amazon reviews, where someone said that “The USB ports are underpowered/not load protected enough…overall, it’s a great board, if you can avoid damaging the USB ports”. In any event, I think I’ve tried everything, and I’m pretty sure what I’m left with is a hardware failure. I plan to RMA the board with Netgate soon.

So, following up on Episode 22, Project Yocto Success!, I continued working on building a MinnowBoard Linux image using the Yocto project. From last time, I was halfway through the build. But then my seven-year-old dual-core home computer crashed. And the hard disk was wiped out. I guess the 48-hour Yocto builds took too great a toll.

Where does this leave me? Well, this weekend, I finished ordering all of the parts for my replacement dream machine. AMD Ryzen 7 1700X (sorry Intel, I couldn’t resist the prices; my next dream machine will be Intel-based) with eight cores and 16 threads, 16GB RAM, 500GB SSD, 2TB HDD, NVIDIA GTX 1060. Those Yocto builds should scream then. I’ll keep you all posted on the dream machine build! It might take me a couple of weekends, so my blogging may be a little less prolific; stay tuned.

It’ll be nice to get a new, fast machine. Some of the work I need to do with SourcePoint, such as running CScripts, requires a lot of horsepower from the remote host. For more information on some of these Python-based massive scripts, see our eBook, SourcePoint CScripts Support (note: requires registration).

Alan Sguigna