The MinnowBoard Chronicles Episode 20: Building and Installing Linux, Part 1

I have a little secret to share: even though I may make it look easy, getting Linux onto my MinnowBoard is hard, hard work. But it's very rewarding.

In Episode 19 of the MinnowBoard Chronicles, I mentioned that doing a Yocto image build from scratch for the MinnowBoard was at the top of my to-do list. As a matter of fact, after spending a few hours unsuccessfully at this task, I decided to return to the basics: follow the tutorial at first to install Ubuntu, then return to the more complex task.

Unfortunately, somewhere in the middle of all this, my HP USB keyboard stopped working on the MinnowBoard. At first it worked intermittently; then it stopped working entirely. I used CoolTerm on my Mac to do some rudimentary command line entries over the serial connection, but as soon as I exited the UEFI shell and went into the Boot Options screen, I became stuck (the arrow keys did not work).

I tried a lot of different things, including looking at the serial output of the debug log with CoolTerm (to try to trace back to the UEFI code that was failing to initialize with the keyboard), but eventually, I gave up and bought a new keyboard. Eureka! That did the trick. I got to the Boot Manager screen, and selected the EFI USB Device: Boot manager screen

Then the Ubuntu install began, with the dots marching across the screen: Ubuntu setup screen

But, then, boom! I got an error message from initramfs: Ramfs pic

No matter what I did, I continued to get this error. I tried two different USB sticks and still the problem persists. So, I decided to put this activity on hold for now, and return to my goal of using Yocto to build an image, run it on the QEMU emulator, and then flash it into my MinnowBoard. I’ll certainly get back to this later – it’s a necessary step in my learning process.

As I mentioned in Episode 19, I am using a VM on a slow Windows PC at home. But, following the instructions in the  Yocto Quick Start Guide, all seemed to be going according to plan….until I ran out of memory on my hard drive! So, I have to do some cleanup before I can try this again. Stay tuned for Episode 21!

For those who may learn from my mistakes, below is the complete console file from my efforts building the image. I almost got there! And at the bottom is the error message displayed on the screen by the VM, warning of my out-of-memory condition. At the very bottom is a good graphic of my feelings after doing all of this work.

Download Yocto-log

I can’t wait to get this finished so I can begin debugging with SourcePoint! In particular, I’ll be wanting to debug the ASPEED AST25xx, once I’m done. Insufficient space screen

I have no idea what I am doing