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Welcome! 
 
Thank you very much for your SourcePoint purchase! We appreciate you acquiring our 
best-in-class debugger, and hope you enjoy using it. We strive to deliver the most 
powerful, easy-to-use and polished product as possible. So, please feel free to share 
your feedback directly at our support site at https://www.asset-intertech.com/support/, or 
via your favorite social media outlet. 
 
As with any new tool, mastering SourcePoint takes an investment in terms of time and 
effort. JTAG-based debug is a fairly specialized area, and low-level “on the metal” 
firmware development on x86 platforms is even more so. So, in your use of the tool, you 
may encounter behavior that seems non-intuitive or even wrong. You may be 
encountering a tool corner case, a limitation inherent in JTAG or DCI, or even a bug. If 
so, try a few different options as may be referenced in the Troubleshooting section of 
this Guide, and if it persists, give us a call. We are happy to support you. 
 
  

  

https://www.asset-intertech.com/support/
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Boards and Cables 
 
The board covered in this document is the AAEON UP Xtreme i11 board, based upon 
the Intel Tiger Lake CPU.  
 
The Tiger Lake boards come in four flavors: Celeron, i3, i5 and i7. As of this writing, all 
boards are suited for Windows debugging. The Celeron boards is the least expensive 
and supports all the latest Intel debug and trace features such as Intel Processor Trace 
(Intel PT), Intel Trace Hub, Architectural Event Trace (AET), and others. 
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WARNING: 

Do NOT plug a regular USB cable into the target and attempt to use DCI. Specialty 

cables, with VBUS snipped, are required; using a regular USB cable may possibly fry 

your target, or worse.  

The main source to purchase the specialty DCI cable needed for SourcePoint 

debugging is ASSET InterTech. This target has its Type-C port enabled for DCI. If you 

have a debug host with a Type-A port, you’ll need to purchase the part # 

ITPDCIAMCM1MU (1.0 meter) cable. The longer 1.8-meter ITPDCIAMCM2MU cable 

will work as well. If your host has a Type-C port, purchase the ITPDCIC2CD2U1M. 

Using Type-A/C hubs have been seen to work, but are not warranted. Type A/C 

adapters have been seen not to work. 

Contact your ASSET representative to obtain the cable needed for your configuration. 
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BIOS Settings 
 
The AAEON UP Xtreme i11 boards come equipped with an AMI Aptio BIOS that is 
based upon typical Intel Customer Reference Board (CRB) BIOS.  
 
Luckily, the platform comes with all the necessary hardware hooks and firmware straps 
to support Intel Direct Connect Interface (DCI) out of the box.  
 
The USB Type C port on the board is the port of interest: 

 
There are only a few BIOS settings to change for the board to work with SourcePoint 
and DCI: disable the board’s Watchdog Timer (WDT), ensure that Windows doesn’t 
wake it up, and turn on the Intel Trace Hub.  
 
Go into the BIOS Boot menu (this is accomplished by rebooting the board, at the same 
time holding down the F7 key, and you’ll be promoted for the password for the “CRB 
Advanced” BIOS menu. Note that CRB is Customer Reference Board, an Intel 
reference: 
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The password is upassw0rd. 
And that is a number “zero” (0) in the password, not the letter “o”. 
 
Enter Setup, and use the arrow key to move over to the Boot menu. and set WDT Timer 
-> Disabled. If you don’t, run-control will be successful, but the board will power-cycle 
every 30 seconds; putting a real crimp in your debugging! 
 

 
 
 
There is another setting within the CRB Advanced menu to Disable the TCO Timer from 
being re-enabled by Windows; this is set to Disabled by default when shipped from 
AAEON, but if you run into issues with run-control stability, you might want to check this: 
 
CRB Setup > CRB Chipset > PCH-IO Configuration > Enable TCO 

Timer must be set to Disabled. 
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Finally, go to CRB Setup > CRB Advanced > Debug Settings and set 

Platform Debug Consent to Enabled (USB2 DbC): 

 
 

 
 



 
 

©2024 ASSET InterTech, Inc. 10 
  SourcePoint Getting Started Guide – UP Xtreme i11 
 
 

Remember to do a “Save & Exit” with the F4 key after the changes! Otherwise, 
your changes won’t be saved. 
 
Power Tip: We have observed that, on very rare occasions, the saved settings that 
you’ve made will be undone by a “BIOS restore”. If you begin to observe strange 
effects, like autonomous platform resets while in run-control mode, check to ensure that 
the changes you’ve made have not been undone. 
 
You are now ready to test your connection, and then launch SourcePoint and begin 
debugging. 
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DbCStatus.exe: Red is Bad, Green and Yellow are Good 
 
Luckily, there is a convenient application in the SourcePoint install directory that will tell 
you that the DCI driver is successfully installed on your computer, and it is possible to 
make a connection between SourcePoint and the target. 
 
Navigate to C:\Program Files (x86)\Arium\SourcePoint 7.12.53 (where 53 

is your current SourcePoint release), and launch the DbCStatus.exe. You should see 

the red ball, indicating that there is no connection: 
 

 
 
Ensure that the Type-C cable is firmly connected to both the host and target, and power 
up the UP Xtreme i11. In a moment the ball should turn green: 
 

 
 
Let the platform boot to the UEFI shell. Congratulations! You have a working DCI 
connection. It’s smooth sailing from here. 
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Power Tip: If you are using SourcePoint WinDbg for debugging this board, and have 
Windows already installed, there may be situations where you want to go to BIOS setup 
before booting all the way up to Windows. In this case, press F7 after powering on to 
stop at the BIOS setup. 
 

Power Tip: The very latest version of the Celeron board will not power up successfully 
after a power cycle. Here’s the workaround: 
1. Apply power back to the target. You will see that it doesn’t power up, and the blue 

light does not light up on the power switch. 
2. Unplug the DCI cable from the Type-C plug. 
3. The board will start to power up. Press F7 and you will stop at the UEFI menu 

password screen.  
4. Hot Plug the Type-C cable back in. Your DCI connection will be restored, and you 

will see the DbCStatus ball turn green. You may continue your Windows debugging 
session. 
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Getting Started with SourcePoint 
 
When you launch SourcePoint for the first time, you will see the main screen, mostly 
gray: 
 

 
 
 
SourcePoint uses Projects (files with suffix .prj) as containers for your debugging 
session. You can create as many Projects as you want, with all your own preferences 
saved. Often, once you have the SourcePoint Project configured to your liking, you’ll 
save it and use it repeatedly during your separate debugging sessions. Other users may 
wish to save a separate Project for each separate debugging session. That’s really a 
matter of user preference and what you’re debugging – it’s your choice. 
 
Now it’s time to create the Project. Under File > Project… select New Project: 
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You’ll be presented with the New Project Wizard (NPW). The emulator connection 
should be via DCI: 
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After hitting Next, you’ll be prompted for the Project Name, Location to store the 

Project, and the location of the Target Configuration file: 
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Note that the Target Configuration (TC) files located in C:\My 

Documents\Arium\Targets are used in conjunction with the jtag-devices.xml 

file to define the specific silicon and SourcePoint settings necessary to ensure a 
successful DCI connection.   
 
For the UP Xtreme i11 boards, custom TC files have been created, so you shouldn’t do 
an Identify Target to automatically select the TC file of interest. Rather, manually 

select the specific TC file that is customized for this target (TGL\UP-Xtreme-

i11_DbC.tc) and hit Open: 
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Then, your screen should look something like this, after you’ve replaced the default 
Project file File name with your preferred name (in this instance, My Tiger Lake Project): 
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Hit Next, then Finish, and SourcePoint should successfully connect to the target. You 

should see “JtagTest: Successful operation” followed by “Configuration 

state: Connected” in the Status bar at the bottom left: 

 



 
 

©2024 ASSET InterTech, Inc. 19 
  SourcePoint Getting Started Guide – UP Xtreme i11 
 
 

 
 
Now the fun part begins. Click on the buttons at the top to set up the Viewpoint, Code, 
Command, Registers and other windows to your own preference. Move the windows 
around and resize them to take best advantage of your available screen real estate. 
You can right-click in the title bar of each window to change its type and, for example, to 
dock the window to the bottom, right side, etc.  
 

 
 
A sample layout is below: 
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Power Tip: the window layout can be saved as a separate file. That way, when you 
create a new Project, you can just Load the layout file separately, without having to 
create and move the windows around again. Choose File > Layout > Save 

Layout… to create a .lyt file, and then do a Load Layout… to save yourself time every 

time you create a new Project. 
 
Power Tip: Exploring Options > Preferences… and some of the other menu items 

may give you some more labor-saving ideas. For instance, I like to ensure that both 
Load last project on startup and Save project on exit are disabled. 

This gives me more control on entry and exit from the application: 
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Others prefer to check Save project on exit. It’s a matter of preference. 

 
This is a good point to do a Project > Save Project…  That way, you don’t have to 

start all over, if for some reason your project gets messed up. 
 
At this point, you are ready to fully begin your debug session. Many of the operations 
can be accessed via the toolbar at the top of the screen. You can issue a Stop on the 

target, Step Into, Reset and halt at the reset vector, set some breakpoints, Go to the 

breakpoint, and so on. Use the buttons at the top, in the SourcePoint Icon toolbar 
section, to initiate these actions. Use the function keys (i.e. F8 for Step Into) as you gain 
experience. 
 



 
 

©2024 ASSET InterTech, Inc. 22 
  SourcePoint Getting Started Guide – UP Xtreme i11 
 
 

 
 
Hit the Refresh button in the Code window after the first Stop. This is only necessary 

once, to get out of Safe Mode; the Code window will automatically refresh with all run-
control operations (stop, go, single-step, etc.) afterwards. 
 
Refer to the SourcePoint User Guide in your install directory for detailed instructions on 
using all of the tool’s features.  
 
The board will halt automatically at the reset vector when you hit the SourcePoint Reset 
button (don’t do this yet!): 
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This is NOT desirable, because the latest AAEON Tiger Lake boards have issues 
recovering from the reset vector to implement AET. It is recommended that you disable 
the default halt at the reset vector by going to the Options > Emulator Configuration > 
Target Reset and click on “Run the target” in the “After SourcePoint reset” box: 
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Congratulations, you have mastered SourcePoint’s basic capabilities, and are using 
run-control. Many users are content to just use these basic operations, because run-
control by itself is very powerful. However, if you wish to master the product and use 
some of its more advanced features, read on. 
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Advanced Topics: Using Trace 
 
Trace is by far one of the most useful debugging utilities for triaging the most difficult, 
hard-to-reproduce bugs. Fortunately, the Tiger Lake CPU is equipped with all the latest-
and-greatest Intel trace logic, and SourcePoint supports them all. 
 
Let’s look at a few of them, and how to configure their use in SourcePoint. 
 

First Step: Configuring the Intel Trace Hub 
 
Event tracing on the TGL platform is accomplished by the Intel Trace Hub. Fortunately, 
using DCI, events supported by the Intel Trace Hub can be streamed directly out of the 
system, well before Windows boots. 
 
Boot to the UEFI shell. This is accomplished by powering on the target, and pressing 
the F7 key until you come to the password entry screen. Note the Power Tip above that 
references the newer Celeron boards, and the workaround necessary to get the target 
to power up.  
 
Click on the Trace button in the toolbar at the top, to open the Trace window; then click 

on the Configure… button; then click on the Trace Hub tab. Set the settings as 

below: 
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Architectural Event Trace 
 
Once the Trace Hub has been enabled for the features you need, click on the AET tab, 

select All as Processors to trace, and select RDMSR/WRMSR and Port In/Out 

as events to trace: 
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Now, you can simply do a Go/Stop to capture the event trace data. Below shows using 
the Command window to simulate a break on any read/write of port x’CF8’, the PCI 

CONFIG_ADDRESS. This is done by typing the following into the Command window: 
 
go til cf8io 

 
This will run the target until the next IN or OUT to CF8.  
 
After issuing the command, you’ll see something like this: 
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Scrolling up a little, you’ll see a mix of Port In/Out and RDMSR/WRMSR, all 

timestamped. 
 
Power tip: The Last Branch Record (LBR) stack associated with each event can be 
captured as well. This is a very powerful debugging utility, especially when 
troubleshooting code execution leading up to events before system memory is initialized 
and Intel Processor Trace is available. 
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Intel Processor Trace 
 
Intel Processor Trace (Intel PT) is available only after system memory is initialized.  
 
It’s easy to set up. Click on the Trace button in the top toolbar, click the Configure… 

button, click on the Intel PT tab, put p0 in Processors to trace, and be sure 

that TSC and Cycle accurate under the Timestamp heading are enabled: 

 

 
 
That’s all. Then use the go til cf8io trick to capture some instruction trace data: 
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There’s a lot more that you can see and do with these Trace utilities. SourcePoint can 
use Intel PT to display a Call Chart and Call Tree. You can open up Code Tracking 
windows that update dynamically as you walk through the code, showing you exactly 
where you are and the interaction between code and events. When you have source 
and symbols available, the firmware flow becomes much more intuitive and visual. 
Indulge your curiosity and imagination. 
 
The video at https://www.asset-intertech.com/wp-content/uploads/2021/11/UP-Xtreme-
i11-Getting-Started.mp4 shows some of these capabilities. The SourcePoint User Guide 
also provides a very thorough, comprehensive review of the tool. And visit our 
SourcePoint Academy for helpful “How To” content. 
 
 
 
 

  

https://www.asset-intertech.com/wp-content/uploads/2021/11/UP-Xtreme-i11-Getting-Started.mp4
https://www.asset-intertech.com/wp-content/uploads/2021/11/UP-Xtreme-i11-Getting-Started.mp4
https://www.asset-intertech.com/sourcepoint-academy/
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Troubleshooting Tips 
 
At some point, you’ll run into something strange. We’re the first to admit that JTAG-
based run-control and trace are not always deterministic. JTAG is a 30-year hardware 
protocol, and when something goes astray at a very low level, SourcePoint tries to (but 
sometimes doesn’t) recover gracefully. There will be times that the board will power 
cycle on its own. Or the firmware thinks that a thread is running but gets out of sync with 
the SourcePoint software, which thinks it’s halted. Or the DbCStatus.exe ball stays red 
instead of turning green, while you swear you have a good DbC connection. Sometimes 
you have no choice but to quit SourcePoint and power cycle the target. That usually 
clears up the one-of’s. But if the issue is repeatable, we ask that you collect as much 
information as you can, and open a ticket with us at https://www.asset-
intertech.com/support/. We’ll respond as soon as possible. 

 
In the meantime, here are a few errata that we’ve noticed on the UP Xtreme i11, and 
the steps needed to mitigate. 
 

Firmware gets out of sync with software 
 
On the host PC using DCI, functionality is roughly partitioned between software 
(SourcePoint application with its GUI) and a process called AssetDCI. Broad-brushing it, 
SourcePoint software on the host communicates with AssetDCI, that encapsulates 
JTAG traffic into packets which are sent to the PCH, which in turn performs the JTAG 
mastering function.  
 
Somewhere along the line, the firmware may get out of sync with the software. You may 
see symptoms like: 
 
In the Viewpoint window, the threads are shown as Running, whereas the Status Bar at 
the bottom right shows Stopped. 
 
P0 in the Viewpoint window is Running, with one or more threads below it are in the 
Stopped state. 
 
If this happens, you’ll likely have to quit SourcePoint, kill the AssetDCI process (see 
below), power-cycle the target, then start over. Sorry. Then please enter aalog = 

20987 in the Command window to get verbose logs, and try to reproduce. We’re 

extremely interested in these cases, so capture the verbose logs in the Log window and 

send to us. 
 
 

Trace buffer overflows 
 
DCI traffic processing has its limitations. When you try to collect too much trace data, 
the trace buffer overflows, causing aberrant behavior. 

https://www.asset-intertech.com/support/
https://www.asset-intertech.com/support/
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Although the trace data is highly compressed, some trace sources, specifically with 
AET, running through the Trace Hub can exceed the capacity of the USB 2.0 
connection. In theory running at 480Mbps, in practicality SourcePoint can only process 
trace data at approximately 100Mbps. Beyond that, we collect ~ 20kB of trace data 
before a buffer in SourcePoint overflows, and we don’t recovery gracefully. 
 
You’ll see these symptoms of this occurrence in the SW/FW Trace window: 
 

 
 
A few of these overflows are no big deal. But, if you’re tracing a huge amount of data, 
SourcePoint may spin, as it tries to process all that data, and deal with the mess. 
Sometimes, after maybe a few minutes, it recovers. Sometimes, you end up in limbo. 
 
The only solution at this point is to quit SourcePoint, do an End task on the AssetDCI 

Background process, power cycle the target, and start over:  
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Ultimately, we’re working on improving the performing of the AssetDCI driver, and 
behaving more graciously when an overflow is encountered. But, in the interim, it is key 
to ensure that the trace data collected is relatively “sparse”. Focus your debugging in 
the specific area of interest. Don’t try to collect all Port IN/OUT from the reset vector all 
the way through to the UEFI shell. At 750K I/Os per second, you’ll swamp the host 
debugger processing, and you can’t deal with all that data anyway. 
 
Note that this only happens with AET – that is, you can only overflow by collecting too 
much AET data. It does not apply to LBR, SW/FW Trace, SVEN, or Intel PT. It may take 
some trial and error to limit the scope of your event data collection. 
 
 

Intel Processor Trace – Slow! 
 
When you configure Intel PT, you can specify the size of the buffer in system memory to 
collect trace data: 
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Note that Intel PT directs instruction trace data to system memory. Although highly 
compact and efficient, we are not streaming over DCI to the host in this case; we buffer 
the code execution data until the platform is halted, at which point SourcePoint uses 
JTAG over DCI to collect the trace data out of system memory, reconstruct and display 
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it. JTAG operates at fairly low speeds, and for large buffer sizes the transfer of all that 
data can be slow. It starts to become noticeable beyond a buffer size of 64kB.  
 
SourcePoint compensates for that by only pulling in the trace data that’s local to the 
code display you are in. Scrolling up in the Intel PT window will prompt SourcePoint to 
pull in more trace data, and display it. Be patient when this happens. If you try to collect 
1GB of data from system memory over JTAG, it will take a long while for this all to be 
available. Displaying the Call Chart for this much data will take a while. You’ll see this 
after initial trace data collection (that only takes a few seconds), but scrolling to the top 
of the Intel PT window with a 1MB trace buffer (which gives you ~ 300ms of execution 
trace data) takes ~30 seconds, and then doing a Call Chart takes over 10 minutes. Be 
patient. 
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My board is not booting – what now? 
 
Once in a while, especially during an intense debug session, we have found that the 
target goes into la-la land. You get to the UP splash screen, and then it just stops. Or 
the screen stays black. SourcePoint run-control continues to work, but it won’t boot all 
the way up to the UEFI shell. Quitting SourcePoint, unplugging the DCI cable, killing the 
AssetDCI process, knocking out the AssetDCI process – all are good steps in this 
instance, when you need to recover.   
 
But then, once in a while, you wait the needed 20 seconds; and it doesn’t boot. The 
screen stays blank or frozen. We know that happens with the newest Celerons, and 
there’s a workaround for that, but this might not be the issue. 
 
Don’t panic! For reasons we’re not sure of just yet, after about 60 seconds, the board 
“wakes up” and should boot all the way to the UEFI shell.  
 
Clearing the CMOS on the target has also been known to help when it still won’t boot 
up. There’s only one thing: it has gone back to the factory settings, so you’ll need to 
reset the WDT timer, and perform the other steps, as per BIOS Settings section in this 
manual. 
 
Then, you’ll be back in business. 
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Conclusion 
 

Thank you for getting this far! We hope that you have enjoyed the ride, and are using 

the power of SourcePoint successfully in your debugging and learning journeys. 

Feel free to browse the SourcePoint Academy at https://www.asset-

intertech.com/sourcepoint-academy/ for helpful reference guides, help material and 

“how to” videos. 

If you ever have any questions, please call, email or open a Support Case here: 

https://www.asset-intertech.com/support/. We’ll be glad to help!  

https://www.asset-intertech.com/sourcepoint-academy/
https://www.asset-intertech.com/sourcepoint-academy/
https://www.asset-intertech.com/support/

